Device Guide

Back to all apps

LEGO® MINDSTORMS® Robot Inventor

The easiest way to find out whether your device works with the LEGO® MINDSTORMS® Robot Inventor experience is to find and download the app. Devices that can download and install the app from official app stores will likely work with our products.

Because of the significant number of different models, variants, and manufacturing standards of available devices, we can only assure the compatibility of devices that are actively tested internally. If your device cannot find and download a particular LEGO app from an official app store, this means that your device does not support that product.

  • iOS compatibility

    To know which operating system your iOS device is running follow this quick guide:

    1. Open Settings
    2. Scroll down and tap General (Gear icon)
    3. Tap About
    4. The OS version of your device is shown next to Software version in the second row.

    Hardware

    • iPhone SE, iPad Air 2 and iPad Mini 4 or newer

    Operating System

    • Requires iOS 13 and newer
  • macOS compatibility

    From the Apple menu in the corner of your screen, choose About This Mac. You should see the macOS name, such as macOS Mojave, followed by its version number. If you need to know the build number as well, click the version number to see it.

    Hardware

    • 1.5 GHz Intel® Core Duo processor - or equivalent or better
    • 4 GB RAM
    • 2 GB available storage space
    • Bluetooth 4.0 or above

    Operating System

    • MacOS Mojave 10.14 or newer
  • Android compatibility

    To know Android device and operation system your device is running follow this quick guide:

    1. Swipe down from the top and tap the Gear icon (System Settings)
    2. Scroll towards the bottom and tap About Phone
      Depending on your device you will either see Android Version defined here, or you may need to follow the next step to view it.
    3. Tap Software Info
    4. The OS version of your device is shown under Android Version

    Hardware

    • 4.5” display or larger
    • 3 GB RAM
    • 3 GB available storage space
    • Bluetooth 4.0 or above

    Operating System

    • Android 7.0 or above
  • Windows compatibility

    To find out which version of Windows your device is running, press the Windows logo key + R, type winver in the Open box, and then select OK.

    Here’s how to learn more:

    1. Select the Start button > Settings > System > About .
    2. Under Device specifications > System type, see if you’re running a 32-bit or 64-bit version of Windows.
    3. Under Windows specifications, check which edition and version of Windows your device is running.

    Hardware

    • 1.5 GHz Intel® Core Duo processor - or equivalent or better
    • 4 GB RAM
    • 2 GB available storage space
    • Bluetooth 4.0 or above

    Operating System

    • Windows 10, version 1809 or newer
  • Fire OS compatibility

    Follow these steps to locate your OS version:

    1. Swipe a finger down from the top of the tablet.
    2. Tap Settings.
    3. Tap Device Options.
    4. Tap System Updates.
    5. Your OS version will be displayed toward the top of the screen.

    Hardware

    • Bluetooth 4.0 or higher
    • 3 GB ram
    • Quad core processor 1.3 ghz

    Operating System

    • Fire OS 7 or above

Compatible devices

The following are the devices and their operating systems that the LEGO Group is using to validate the app experience. This list of validated devices may change at any time and without any notice. We will do what we can to keep this list as up to date as possible.